vmware-server-2.0.2 kernel-2.6.32.5

Après plusieurs tentatives de compils infructueuses (2.6.32.1, 2.6.32.2) la dernière version du noyau ne pose pas de problèmes pour la compil des modules vmware-server-2.0.2.

Install réalisée sur une ubuntu 8.04 x86_64 disposant d'un noyau perso (fichier de config ici)

Il y a, certes, quelques warnings durant la compil des modules mais apparemment rien de bloquant. J'accède aux vm linux et windows sans soucis via la console.

Les modules et le script vmware-config.pl patchés sont les mêmes que ceux utilisés pour le 2.6.31.5 et le 2.6.32.

Commentaires

1. Le vendredi, août 26 2011, 22:24 par chanquier

Bonjour,

j’essaye deseperement d'installer un vmware-server 2.0.2 x64 sur une debian kernel 2.6.32-5-amd64.
J'ai bien téléchargé et décompressé votre patch, mais je ne comprend pas comment m'en servir... Vous parlez du fichier vmware-install.pl patché, mais il n'est pas dans l'archive...
Merci

2. Le dimanche, août 28 2011, 09:53 par Patrick Menier

Désolé, effectivement petit oubli. Tu trouveras sur le lien le tarball qui contient les modules et le vmware-config patchés. Prends bien soin de sauvegarder toutefois tes fichiers d'origine avant de les remplacer par ceux-ci.

http://blogpmenier.dynalias.net/docext/vmware202/vmware202.tgz


3. Le mardi, août 30 2011, 14:48 par nonews

je ne vois pas ou les tarballs vont. please help.

4. Le vendredi, septembre 2 2011, 08:53 par Patrick Menier

Tu sauvegardes tes fichiers d'origine et tu places ceux du tarball à cet endroit :

root@p733:/usr/lib/vmware/modules/source# ll
total 7080
drwxr-xr-x 3 root root 4096 2009-10-31 10:45 .
drwxr-xr-x 5 root root 4096 2009-10-31 10:43 ..
-r--r--r-- 1 root root 655360 2009-10-31 10:44 vmci.tar
-r--r--r-- 1 root root 1034240 2009-10-31 10:44 vmmon.tar
-r--r--r-- 1 root root 798720 2009-10-31 10:45 vmnet.tar
-r--r--r-- 1 root root 512000 2009-10-31 10:45 vsock.tar
5. Le lundi, mars 12 2012, 17:49 par G-Rom

Hello,

Un grand merci pour ton patch, qui m'a bien été utile ! ;-)

6. Le mercredi, mars 14 2012, 08:23 par Patrick Menier

De rien :) Je croise juste les doigts pour que le 2.6.32 fasse de vieux os...