pme2@p733:~$ lsb_release -a
LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID:    Debian
Description:    Debian GNU/Linux 7.8 (wheezy)
Release:    7.8
Codename:    wheezy

Pour pouvoir installer la version 2.6 il faut modifier le sources.list comme indiqué sur la page de téléchargement de qgis (http://www.qgis.org/fr/site/forusers/alldownloads.html#debian)

Ensuite un simple apt-get install qgis installera la V-2.6 mais celle-ci n'aura pas le support des ecw. Pour cela il faut aller chercher le SDK de ERDAS à cette adresse (je ne laisse pas le fichier en téléchargement car il pèse tout de même 160 Mo):

http://download.intergraph.com/?ProductName=ERDAS%20ECW/JPEG2000%20SDK       Lien valide à l'heure où j'écris ce billet. En cas de soucis balancer un message, je laisserais le paquet sur un cloud...

Comme expliqué sur pas mal de sites il faudra également récupérer le paquet gdal-ecw-src (celui-là je vous le laisse [ici| et [là] )

 
Sur ma machine j'ai installé la version raring par un simple dpkg -i le-paquet.deb. Il y aura peut-être quelques dépendances à installer notamment le méta-paquet build-essential mais tout se passe bien.

L'extraction et l'exécution du binaire récupéré chez Erdas vous créera la structure de répertoire suivante:

pme2@p733:~/Téléchargements/qgis$ ll
total 185224
drwxr-xr-x 3 pme2 pme2      4096 janv. 26 10:45 .
drwxr-xr-x 8 pme2 pme2      4096 janv. 11 17:10 ..
-rwxr-xr-x 1 pme2 pme2 163958130 janv. 20 16:11 ECWJP2SDKSetup_5.1.1.bin
drwxr-xr-x 2 root root      4096 janv. 25 19:45 ERDAS-ECW_JPEG_2000_SDK-5.1.1

Attention Prendre soin de sélectionner Desktop Read Only dans la liste des options d'install. Le répertoire ERDAS-ECW_JPEG_2000_SDK-5.1.1 contient un sous-répertoire Desktop Read Only que j'ai déplacé et renommé dans /usr/local:

# mv "/home/pme2/Téléchargements/qgis/ERDAS-ECW_JPEG_2000_SDK-5.1.1/Desktop Read Only" /usr/local/qgis-ecw

Ensuite on compile:

# gdal-ecw-build /usr/local/qgis-ecw  et normalement c'est tout.. Eh bien non ! En fait le module ecw s'installe dans /usr/lib/gdalplugins/1.10. mais la version de gdal est la 1.9:

pme2@p733:~$ gdalinfo --version
GDAL 1.9.0, released 2011/12/29

Il faut donc logiquement renommer le répertoire 1.10 en 1.9 et c'est tout bon:

pme2@p733:/usr/lib/gdalplugins$ ll 1.9/
total 848
drwxr-xr-x 2 root root   4096 janv. 26 11:12 .
drwxr-xr-x 3 root root   4096 janv. 25 19:54 ..
-rw-r--r-- 1 root root 857571 janv. 25 19:53 gdal_ECW_JP2ECW.so

pme2@p733:/usr/lib/gdalplugins$ gdalinfo --formats | egrep -i 'jp|ecw'
  ECW (rw+): ERDAS Compressed Wavelets (SDK 5.1)
  JP2ECW (rw+v): ERDAS JPEG2000 (SDK 5.1)
  JPEG (rwv): JPEG JFIF
  JPEG2000 (rwv): JPEG-2000 part 1 (ISO/IEC 15444-1)

Doc complémentaire qgis / postgis /postgresql conversion pdf de la page: http://learnosm.org/fr/advanced/postgis-configuration/